Java SE 1.6 and Firefox not compatible?

After I had just installed├é┬áMozilla Firefox 2.0.0.5, a pop-up window informed me that the Java SE 1.6 console was not compatible with that version of Firefox. Don’t panic though, pretty much everything Java will still work in your browser. Here’s Sun explanation on the subject:

The Java Console menu item disappears in Firefox after it is updated to 2.0.0.1. This is caused by the fact that the maxVersion parameter of the Java Console “extension” is set to 2.0, and not 2.0.0.* or 2.0.* (either will suffice). This issue may be present in multiple platforms.

This should be fixed in Java SE 1.6 Update 2. I’ve been unable to verify this since I’m still at work.

Leave a comment